Commodore Amiga 2000

Ho comprato questo Amiga 2000 di seconda mano nel febbraio del 1997 tramite un annuncio su un giornalino locale; era di un ragazzo che aveva anche un Amiga 1200 e decise di vendere il 2000 dato che non lo usava più.

Ci sono state diverse revisioni della scheda madre di questo computer: quello dell’annuncio aveva la 6.3, una delle ultime; era inclusa anche una scheda Commodore “Bridgeboard” con un processore 286 per emulare un PC.

Purtroppo con questo computer ho imparato a mie spese (letteralmente!) che è meglio togliere le batterie interne se il computer non viene utilizzato… infatti un paio di anni fa l’ho acceso per fare alcune prove ma non si avviava: la batteria era completamente andata e aveva fatto fuoriuscire liquido corrosivo sulla scheda madre rendendola inutilizzabile. Una di quelle cose che si sanno ma si pensa sempre “a me non succederà”, e invece il danno era irreparabile ed ero davvero disperato!

Sono riuscito a trovare una scheda madre nuova su eBay Germania: un professore aveva acquistato molti anni prima un Amiga 2000 e per sicurezza aveva comprato una scheda madre di ricambio per ogni evenienza, di cui ormai non aveva più alcun bisogno.

8 thoughts on “Commodore Amiga 2000

  1. Gabriele

    Mi stai facendo temere per l’integrità del mio Amiga 2000B, che conservo nel box di mio padre dal lontano 1998…
    Ha una configurazione niente male, con una scheda SCSI della GVP, con espansione di 2Mb fastram e un disco da “ben” 81 Mb. Ho anche montato la schedina per switchare tra Kickstart 1.3 e 2.0, con le due Rom originali e una levetta derivata sul retro del case.
    Ho paura di provare a riprenderlo ed accenderlo… :)

  2. Giacomo Vernoni Autore articolo

    Il mio 2000 se non ricordo male ha una schedina con il Kickstart 1.3 e 3.1; quest’ultimo si attiva accendendo il computer tenedo premuto il tasto sinistro del mouse. Ma è un po’ che non lo accendo, in questi giorni verifico dato che una persona mi ha chiesto di testare il funzionamento di una tastiera.
    Per quanto riguarda la batteria, vai a prendere il 2000 prima che puoi, e prima di accenderlo cerca di controllare se un’eventuale fuoriuscita di acido dalla batteria ha danneggiato la scheda madre… il computer è in un box dal ’98, ma la batteria è lì da un quarto di secolo!

  3. Gabriele

    L’ho ripreso dal box di mio padre (uno dei luoghi in cui gioco a tetris, per dirla alla tua maniera. :)) approfittando dell’assenza dei miei. L’ho introdotto furtivamente in casa loro, avendo le chiavi. :P
    L’ho aperto e mi sono molto scoraggiato: la zona intorno alla batteria era tutta verdognola e maculata. Ci ho passato un po’ di carta da cucina asciutta per capire la natura della zozzeria: era verderame!! E’ arrivato fino ai primi contatti dello slot più vicino al 68000.
    Ho preso il tester e ho fatto un bel po’ di test di continuità. Sembrava tutto a posto. Poi ho misurato la batteria: ZERO VOLT!
    Mi sono fatto coraggio, ho collegato il cavo di alimentazione, ho switchato il tasto di accensione e… luce fu!! ^__^
    E’ partito anche l’hard disk! Che gioia immensa sentire il floppy e il suo allegro click… click.. click… :)
    Adesso sono alle prese con un Mac IIci comprato via ebay a 10,45€, dichiaratamente guasto.
    Voglio rimetterlo in piedi! :)
    Ispirato da questo blog, ne sto allestendo uno anch’io. Non ho ancora una collezione del tuo livello, ma piano piano…
    Saluti. :)

  4. Gabriele

    Ehilà. :)
    Non ho ancora dissaldato la pila. Si tratta di rimuovere tutta la motherboard per accedere al lato saldature, ed è un lavoro che richiede un po’ di spazio.
    Al momento il tetris sta avendo la meglio su di me, e le file sono quasi in cima. ^__^

  5. Gabriele

    Ciao Giacomo.
    Alla fine ho dissaldato la vecchia batteria, pulito le zone “infette” con del comune disinfettante che avevo in casa, a base di alcol, mischiato con un po’ di acqua distillata.
    Ho poi effettuato una modifica, saldando sulla motherboard tre connettori presi da una fila di strip, al posto dei tre contatti della batteria, ai quali collegherò la modifica per metterci una comune pila a bottone (CR2032).
    La macchina è partita, ma ogni tanto lo schermo si oscura, ed è necessario resettare. Credo ci sia qualche condensatore capriccioso. Almeno spero sia solo questo.
    In effetti il quadro che mi si è parato davanti era davvero sconvolgente.
    Ne parlo nel mio modesto blog. :)
    Un saluto,
    Gabriele

  6. Giacomo Vernoni Autore articolo

    Ho letto l’articolo e guardato le foto… brutta sorpresa… hai controllato le piste con il tester? giusto per essere sicuro che non ce ne sia qualcuna interrotta. Al limite riesci a ripararle con un filo di rame e un po’ di stagno.

  7. Gabriele

    Sì sì, è completamente funzionante, e i vari test di continuità che ho fatto sono andati a buon fine.
    Quando lo schermo si oscura, a volte riesco a “riprenderlo” senza resettare, semplicemente chiudendo il programma che ha provocato l’oscuramento.
    Mi è capitato con Protracker, Amos e un paio di programmi che scrissi con questo linguaggio. Hanno in comune una modalità grafica a parte, differente da quella del Workbench Screen. Chiuso lo screen del programma, l’Amiga si riprende. Molto strano, anche perché il chipset, lo slot video e il connettore RGB sono ben lontani dal macello fatto dalla batteria.
    Per questo credo si tratti di qualche condensatore capriccioso, ma fare il recap di quella enorme motherboard è un lavoro!! Non se ne parla! :)

I commenti sono chiusi.